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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
l Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

l On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “clickMaxwell 2D > Excitations > Assign >Wave Port.”

l Labeled keys on the computer keyboard. For example, “Press Enter” means to
press the key labeled Enter.

l Italic type is used for the following:
l Emphasis
l Titles of publications
l Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and
contains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"
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This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon or a partial view of the ribbon is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an
application arranged by category such File, Edit, View, Project, etc. An example of a
typical user interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation >Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached and to include software files as applicable. This
allows more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular window
or window tab is open. In this case, the help page associated with the command or open dialog
box is displayed automatically.
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1 - Introduction
Ansys Maxwell is an interactive software package that uses finite element analysis (FEA) to
simulate (solve) electromagnetic field problems. Maxwell integrates with other Ansys software
packages to perform complex tasks while remaining simple to use. This guide will focus on
Maxwell's integration with Ansys ECAD, and it will show how to enhance an ECAD design using
Maxwell's MCAD tools.

Maxwell can be used for PCB layout analysis. It can calculate noise vibrations at low frequency,
so it can be used to do the following:

l Understand how permanent magnets located in proximity of PCB influence the noise
l Reduce noise issues by computing Lorentz forces between traces
l Model deformation and vibrations due to harmonic forces
l Obtain acoustic response of boards resulting from vibrations

PCB layouts can be imported into Maxwell and edited from within the Maxwell interface. This
Getting Started Guide will detail the steps required to import and simulate an example layout.

Note: For more details on using 3D layouts in Maxwell, see 3D Transient Solution with
an A-Phi Formulation.

To analyze a problem, you specify the appropriate geometry, material properties, and excitations
for a device or system of devices. The Maxwell software then does the following:

l Automatically creates the required finite element mesh.
l Calculates the desired electric or magnetic field solution and special quantities of interest,
such as force, torque, inductance, capacitance, or power loss. The specific types of field
solutions and quantities that can be computed depend on which Maxwell 3D solution type
you specified (electric fields, DC magnetics, AC magnetics, transient fields and data).

l Allows you to analyze, manipulate, and display field solutions.

For this example, a 3D layout will be imported as a component, so the geometry and material
properties will already be defined. Because this model was created in the HFSS 3D Layout tool,
it includes layer information, so it is considered a 3D layout. But when it is imported into Maxwell,
it is considered as a 3D component.

This design is a power delivery network board; the 3D layout in the HFSS 3D Layout tool is
shown below:

Getting Started with Maxwell®: ECAD Integration
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Below is the 3D layout imported as a component in Maxwell. Note that only select nets are
shown.
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Maxwell will be used to identify the simultaneous switching noise in the device.

Introduction 1-3
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Goals
Your goals inGetting Started with Maxwell: ECAD Integration with Maxwell are as follows:

l Determine the force on the PCB due the current and voltage excitations.
l Determine the effect a permanent magnet has on the PCB

You will accomplish these goals by doing the following:

1. Import a PCB archive into HFSS 3D Layout.
2. Assign ports in 3D layout from HFSS.
3. Assign a mesh to the layout in HFSS.
4. Create a Maxwell 3D transient A-Phi design.
5. Create a region set a boundary of fringing field computation for the design and assign a

flux tangential boundary condition.
6. Assign current and voltage excitations.
7. Set up and run the transient simulation, which will include a force computation and a

harmonic force computation.
8. Plot the layout force, terminal current, B magnitude, J magnitude and vector results.
9. Use Maxwell's MCAD tools to add a permanent magnet to the PCB board, and rerun the

simulations.

Introduction 1-4
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2 - Preparing a 3D Layout
In this chapter you will complete the following tasks:

l Board Import
l Port Assignment
l Solution Setup
l Mesh Operations

Import the PCB Layout
To open the PCB layout:

1. Double-click the Ansys Electronics Desktop icon on your desktop to launch
Ansys Electronics Desktop.

You can also start Ansys Electronics Desktop by clicking Start > All Programs > Ansys
EM Suite [version] > Ansys Electronics Desktop [version] from the Windows Start
menu.

2. Click File >Open Examples, then,

a. In the Open dialog box that appears, click the parent folder icon once to move up
one level above the Examples folder.

b. Double-click the Help folder and then the Maxwell folder.

c. Select the SNN_ECAD_3DL.aedtz file.

Note: The .aedtz file is an archive file. Archive files ensure that the user has all
the files needed to run a particular example.

3. Select the Project File Restore Location for the archive to be unzipped to, and click Save.

The archive file will be unzipped to the directory you select and then automatically opened
in HFSS 3D Layout. Ansys recommends that you select a location other than the
\\Help\Maxwell directory in the distribution so that you can maintain the original files as a
reference.

Note: This file could have been opened directly in Maxwell, but you need to
assign a mesh to the 3D layout from within HFSS 3D Layout.

4. Click File > Save As.

The Save As dialog box appears.

Getting Started with Maxwell®: ECAD Integration
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5. Save the file under a unique name of your choosing.

Explore Design
This design is a power delivering network with a Voltage Regulation Module (VRM) and a
System on Chip (SoC).

Setting Up the Design 2-2

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Maxwell®: ECAD Integration

To view the layer stackup for this design, select Layout > Layers.

Setting Up the Design 2-3
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The nets of interest are GND and VCC. To view these nets:

Setting Up the Design 2-4
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1. From the View menu, make sure the Layers and Nets options are checked.

2. On the right side of the Ansys Electronic Desktop window, click on the Layers tab.
a. In the window that opens, uncheck all the layers except GND and VCC.
b. Uncheck all the other options exceptOutline.

Setting Up the Design 2-5
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3. Click on the Nets tab. In the window that opens, right click on the GND net, and select
Show (Hide All Other).

Setting Up the Design 2-6
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The isolated GND net is shown below. Note that it is red because it is selected in the
canvas.
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4. Reopen the Nets window, and right click on the VCC net and select Show (Hide All
Other).

Setting Up the Design 2-8
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Assign Ports
Next you will select port locations. You will define ports to connect the VCC and GND nets.

1. In Nets window, use the Ctrl key to select both VCC and GND, then right click to select
Show.

Both the GND and VCC nets are displayed in red to indicate that they are visible.

Setting Up the Design 2-9
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2. In the Layers window, uncheck all the layers except Surface,GND, and VCC.
Note that the Surface layer has the connections between the GND and VCC nets.

3. Color the layout by net:
a. Select Layout > Settings.
b. In the Design Options window that opens, check the Color by net.

VCC pins are in magenta, and GND pins are in green:

Setting Up the Design 2-10
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Port1 will be assigned on SoC, and Port2 will be assigned on VRM, as shown below:

Setting Up the Design 2-11
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4. Use the Select icon with the Ctrl key to select both VCC and GND pins that will define
Port1.

5. Right-click and select Port > Create Circuit Ports.

Setting Up the Design 2-12
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6. Repeat the above step for Port2 assignment.

7. In the Project Manager tree, expand the Excitations entry. The ports you created are
listed.

8. Right-click on the first port and select Rename. Name it Port1.

9. Rename the other port Port2.

Setting Up the Design 2-13
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Set Up Solution
1. In the Project Manager tree, right-click on the Analysis entry, and select Add HFSS

Solution Setup > Advanced.

The Setup dialog box appears.

2. The default settings are sufficient, so clickOK.
3. View the default settings in the Edit Frequency Sweep dialog box that opens, then click

Setting Up the Design 2-14
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OK.

Assign a Mesh Operation
In this section, you will assign a mesh to the layout. For ECAD components, the meshing must
be done in HFSS 3D Layout. After the layout is imported into Maxwell, you will further modify the
device to use the Phi mesh, but the initial mesh must be done here.

Setting Up the Design 2-15
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1. Make sure that only VCC and GND are still selected in the Nets window.

2. In the Project Manager tree, right-click on Analysis\Setup1, and select Assign Mesh
Operation > Inside Selection > Length Based.

Note: Length-based mesh operations inside volumes can be applied to non-
model box primitives; the imported layout is considered a non-model.

3. In the Select Geometry dialog box that opens, do the following:
a. Select the layers for the GND and VCC nets as shown below.
b. Check Restrict Length, and setMax. Length for 10 mm.
c. ClickOK.

Note:When you request length-based mesh refinement, you instruct Maxwell to
refine the length of tetrahedral elements until they are below the Max Length
value. The length of a tetrahedron is defined as the length of its longest edge.
Maxwell refines the element edges inside the object until they are equal to or less
than this value. The default value is set to 20% of the maximum edge lengths of
the bounding boxes of each selected object's faces.

Setting Up the Design 2-16
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4. Right-click on Analysis\ Setup1 and selectGenerate Mesh.

Setting Up the Design 2-17

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Maxwell®: ECAD Integration

Note: The meshing operation may take several minutes. You can monitor the
progress in the Progress pane.

5. View the mesh created on GND:

a. In the Project Manager tree, right click on the Field Overlays entry, and select Plot
Mesh.

b. In the dialog box that opens, for the GND net, select <no-layer>, SURFACE,GND,
and Base, then click on Done.

c. To make the GNDmesh more visible, open the Layers tab, and unselect all the
layers exceptGND.

6. View the mesh created on VCC:

a. In the Project Manager tree, right click on the Field Overlays entry, and select Plot
Mesh.

Setting Up the Design 2-18
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b. In the dialog box that opens, for the VCC net, select <no-layer>, SURFACE, VCC,
and Base, then click on Done.

c. To see the VCCmesh, in the Project Manager's tree, expand Field Overlays >
Mesh Plots, then right click onMesh1 and uncheck Plot Visibility.

d. To make the VCCmesh more visible, open the Layers tab, and unselect all the
layers except VCC.

Setting Up the Design 2-19
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3 - Create the Maxwell 3D A-Phi Transient
Design

If you would like, you can create a new project to create the Maxwell design or you can create
another design inside the existing project. The procedure for importing the 3D layout is the same.

1. Click Desktop tab.

2. From the Maxwell drop-down list, selectMaxwell 3D.

3. In the Project Manager tree, right-click on the Maxwell3DDesign entry, and select
Solution Type.

4. In dialog box that opens, select Transient, and check the A-Phi Formulation.

5. ClickOK.

Note: The A-Phi Formulation solver solves second-order Φ for the electrical field,
and solves first-order A for magnetic field. (In order to account the difference in
the order of elements solved, increasing the mesh density in A-Phi should help
achieve the same B field results as T-Omega.)
The A-Phi solver supports multi-terminals with mixed excitation types on the
same conduction path, and it is computationally efficient and flexible for ECAD
PCB and other electronics applications.

Getting Started with Maxwell®: ECAD Integration
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Import 3D Layout to Maxwell
1. Expand theMaxwell3DDesign entry in the Project Manager tree, right-click on 3D

Components and select Browse Layout Component > Browse to Project aedb
Folder.

Note: The Browse Layout Component option is only available with the
Transient A-Phi Formulation.

2. In the Browse window:
a. Navigate to the directory where you have your project.
b. Double click on the SSN_ECAD_3DL.aedb directory.
c. SelectOpen.

Note: An imported 3D layout file can only contain one design; if there are multiple
designs in the layout, the import will fail.

3. In the Insert Layout Component window, click on the Coordinate System tab, and select
the Global coordinate system as the Reference.

Create the Maxwell 3D A-Phi Transient Design 3-2
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4. ClickOK.

The imported PCB is shown below:

Create the Maxwell 3D A-Phi Transient Design 3-3
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5. Modify 3D Layout Component Visualization so that only VCC and GND are shown:
a. In the model history tree, right-click on LC1_1, and select Properties.
b. Click on the Visualization tab.
c. Click on theObject Attributes button.
d. For Display Model, select Net. 
e. Uncheck all nets except VCC andGND: Click on the Show label in the Column to

uncheck all the nets, and then select VCC andGND.
f. Uncheck Show Dielectric.
g. Click Apply andOK in the Object Attributes window.
h. ClickOK in the Properties window.

Create the Maxwell 3D A-Phi Transient Design 3-4

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Maxwell®: ECAD Integration

The modified view is shown below:

Create the Maxwell 3D A-Phi Transient Design 3-5
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Note: If you get an Import Failed error when you import a 3D Layout, it may be
because there in more than one design in the layout. Make sure there is only one
design in the 3D Layout file before importing into Maxwell.

Create the Maxwell 3D A-Phi Transient Design 3-6
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Modify an Imported Layout
After a 3D layout component has been imported into Maxwell, it can be edited:

Right click on the 3D layout component in the Project Manager tree, and select Edit Definition.
The layout will be opened in the Maxwell project for editing.

Create the Maxwell 3D A-Phi Transient Design 3-7
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When you save the 3D Layout design, the modifications will be updated in the Maxwell design.
You may have to modify the 3D Layout component visualization in Maxwell to make sure
components are shown correctly; see Import 3D Layout to Maxwell for details.

Create Simulation Region
In these next steps you will create a region and apply a flux tangential boundary condition to it.
The region sets a boundary for the fringing field computation; the field is only calculated with that
region.

1. From the Draw menu, select Region.
2. Select Pad individual directions.
3. For the +X, -X, +Y, -Y directions, enter a value of 100. For the +Z and -Z directions, enter a

value of 600.
4. ClickOK.

Note: The required size of the region will vary according to the device, but a
general rule is that it should be four to five times larger than the geometry of the
device.

5. Select the Region in the 3D Modeler window, then right-click and select Extend
Selection > All Object Faces.

Create the Maxwell 3D A-Phi Transient Design 3-8
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6. Right-click on the Region again and select Assign Boundary > Flux Tangential, then
clickOK to apply and close the dialog box.

A FluxTangential boundary condition is now listed in the Boundaries folder.

Note: For an ECAD workflow using A-Phi solver, the boundary must be set to
Flux Tangential, which defines H as tangential to the boundary and flux cannot
cross it.

Assign Excitation
When the 3D Layout Component is imported in Maxwell 3D A-Phi Transient solver, the ports
assigned in 3D Layout are automatically mapped into Maxwell as excitations. Users can modify
the excitation source type and excitation value for each assigned port.

1. In the Project Manager tree, expand the Excitations folder, and double click on LC1_1_
Port1 to open its properties.

2. In the Properties window that opens:

a. Set the Excitation Type to Current.

Note: If the row that was labeled Voltage does not change to Current,
clickOK in the Properties window, then reopen.
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b. Assign 10*sin(2*pi*10000*Time) for the current value.
c. Set the unit to A.
d. Optional: When the 3D layout was imported into Maxwell, the ports are interpreted

as floating. This boundary condition will generate correct results, but if you would
like to plot potential, set Negative Terminal to Ideal Ground.

e. ClickOK.

3. Assign a 0 V excitation to Port2.
a. Double click on LC1_1_Port2 in the Excitations folder.
b. For the Excitation Type, select Voltage.
c. Assign 0 V for the voltage value.
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d. ClickOK.

Specify Initial Mesh for Maxwell
1. In the Project Manager tree, right-click onMesh, and select Initial Mesh Settings.
2. For the Mesh Method, select Classic.

Note: Although a mesh was assigned to the device in the HFSS 3D Layout, we
want to further modify the mesh to use the Classic\Phi mesher, which is an
advanced layout-based meshing technology that can produce meshes rapidly
and generate fast and accurate results. It is used for planar structures.
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3. Click on the Advanced tab.
4. Check the Allow Phi for layered geometry (Classic only) option.
5. ClickOK.
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4 - Generating a Solution
Now you are ready to specify solution parameters and generate a solution for the PCBmodel.
You will do the following:

l Set the simulation criteria that determines how Maxwell 3D computes the solution.
l Set up force parameters for layout computation
l Set up a harmonic force calculation
l Validate your design
l Run the simulation

Add Solution Setup
Next, you will add a solution setup to define the simulation time from 0-200 µs in steps of 3.33 µs.

1. In the Project Manager tree, right-click Analysis and select Add Solution Setup.

The Solve Setup window appears.

2. From theGeneral tab:
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a. Set the Stop time to 2*(1/10000), and set the units to s.

b. Set the Time step to 1/10000/30 s.

3. Click on the Save Fields tab.
4. Select Every 1 steps from 0 s to 2*(1/10000) s.

5. Leave other settings to the default, and clickOK.

Set Up Force Calculation for Layout Component
The layout force is caused by current carrying traces that interact with AC field generated by
other sources on the PCB board. This interaction generates Lorentz force, which can cause
mechanical vibration and resonance that leads to potential board fatigue, electrical performance
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malfunctioning, and failures. In the steps below, you will configure Maxwell to output these force
results.

1. In the Project Manager tree, right-click on Parameters, and select Assign > Force from
Layout.

2. In Layout Force Setup window:
a. Select all the layers for the VCC net.

Note: To select all the layers for a net, click on its name in the nets column.

b. Set its Name as F_VCC.

c. In PostProcessing tab, selectGlobal for Reference CS.
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d. ClickOK.
3. Repeat the above process for GND force parameter setup.
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Enable Harmonic Force Calculation
Harmonic force data can be exported from a Maxwell simulation for further mechanical vibration
analysis, for example, in Ansys Mechanical. Harmonic force is not calculated by default; it must
be enabled before running the simulation.

1. From the Project Manager tree, right-click on theMaxwell3DDesign entry, and select
Enable Harmonic Force Calculation.

2. From the Enable Harmonic Force Dialog window'sGeneral tab, for Type, select Element
Based (Volumetric).

3. Click on the Layout tab, select theGND and VCC nets to be calculated.
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4. Click on the Advanced tab, and set the Start At and Stop At settings as shown below, and
clickOK.
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Validate Design and Run Simulation
Before running a simulation, it is best to validate its setup.

1. From theMaxwell 3Dmenu, select Validate Check.

Alternatively, from the Simulation tab, you can click the Validate icon.

The Validate Check tool runs, and after it is complete, the Validate Check window
appears:

For this model, we see that the model, the design settings, and the simulation parameters
were checked and validated. If the tool finds any problem with your design, it will be
reported in this window. Make sure to address any of these issues before you run your
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simulation.

2. Start the analysis: right-click on the Analysis\Setup1 entry, and select Analyze.

Note: This simulation took about 3 hours on aWindows 10 machine with an Intel i7
2.10 GHz processor and 64 GB of RAM. To improve simulation time, Ansys
recommends that you use the Time Decompostion Method (TDM). This feature
requires additional licensing; contact your Ansys support representative for more
details.

Note: If you are rerunning a transient simulation that does not have any changes to the
simulation parameters, you need to Reset to Time Zero; otherwise, Maxwell will not
overwrite the data that is already present because it will not rerun the simulation. You
may need to do this when you upgrade a project to a newer version of Ansys
Electronics Desktop and want to rerun your simulations.
To reset to time zero, clickMaxwell > Analysis Setup > Reset to Time Zero, or in the
Project Manager tree, right-click Setup under Analysis, and select Reset to Time
Zero.
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5 - Analyzing the Solution
Now that you have generated a solution for the PCB design, you can analyze it using Maxwell
postprocessing features. In this section, you will

l plot the layout force and terminal current for the VCC and GND nets
l visualize the flux density and current density

Plot the Force and Current
After your simulation is finished, you will postprocess the results to view the Layout Force and
the Terminal Current.

1. In the Project Manager tree, right-click on Results, and select Create
TransientAPhiFormulation Report > Rectangular Plot.

2. In the Report window:
a. For the Category, select Layout Force.
b. For the Quantity, use the Ctrl key to select F_GND.Force_mag and F_

VCC.Force_Mag.
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c. Click New Report.
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3. Plot the terminal current for both ports:

a. For the Category, select Terminal Current.
b. For Quantity, select TerminalCurrent(LC1_1_Port1_T1) and TerminalCurrent

(LC1_1_Port2_T1).
c. Click New Report.
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Note: If you see a transient spike at first two time steps, it can be ignored as it is a
numerical artifact. You can adjust the time scale to eliminate the numerical artifact
using the Zoom Area icon from the Desktop's View tab.

For a more precise range, right click in the plot window and selectModify Report, then
click on the ... icon beside the Time field to open a dialog box for specifying a time
range.

Field Visualization
Next you will plot the flux density and current density results for visualization.

1. In the Project Manager tree, right click on Field Overlays and select Fields > B >Mag_B.
2. In the Create Field Plot window:

a. Select Plot on surface only.
b. Click on the VCC column label to select all the selectable layers (not all of them are

displayed in the illustration).
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c. Click Done.
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3. Click on the timestamp in the display window, and from the Set View Context window that
opens, select 30 us.

4. Right click on the Plot legend, and selectModify.
5. Click on the Scale tab, and set the scale to Log.

The resulting flux density plot for the VCC net is shown below:
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Note: If you would like to hide the Region (it is hidden in these illustrations), right
click on it in the model history tree, and select View > Hide in Active View.

6. Plot the VCCMag_J results. Remember to set the scale to Log.

Note: To avoid plotting the Mag_J results in the same plot as the Mag_B results,
right click on theMag_B entry in the Field Overlays\B folder, and uncheck the
Plot Visibility option.
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7. Plot the VCC J_Vector results.
You may also need to adjust the arrow size to make the vectors more visible; this can be
done from the Modify >Marker/Arrow tab.
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8. Repeat the above process for the GNDMag_B, J_Mag, and J_Vector plots.

Analyzing the Solution 5-10

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Maxwell®: ECAD Integration

Analyzing the Solution 5-11

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Maxwell®: ECAD Integration

Export Harmonic Force Data
Harmonic force data can be exported for use in other tools such as Ansys Mechanical. To be
able to export this data, you first had to enable its calculation before you ran your simulation; see
Enable Harmonic Force Calculation for more details.

1. From the menu bar, selectMaxwell 3D > Export Transient /Harmonic Force.
2. From theGeneral tab, define the export type, solution setup, and file path as shown

below.

3. From theOptions tab, check theOutput All Frequencies option.
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4. ClickOK to save the data in .csv format.

Warning: Because there is a significant amount of data to export, this operation may
take several minutes.

The index.csv file that is in your top-level project directory reports the location of the exported
data. For this simulation, the Maxwellharforce.csv file is saved to a \\Setup1\DV4 directory in the
project folder.
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6 - Combining ECAD and MCAD
You can add components to an imported ECAD design. In this section you will create a
permanent magnet using Ansys Electronics Desktop MCAD tools and rerun your simulations to
see the effect the magnet has on the PCB board.

Create Permanent Magnet
To create the permanent magnet, you will use Maxwell's MCAD tools to draw it, and then assign
a material to it.

1. From the Draw menu, select Box. If the non-model object warning pops up, select No.
2. If needed, to open the CreateBox dialog box, press F4 on keyboard.
3. Set the following:

a. Position: -14, -32.6, 1.7
b. XSize: 20
c. YSize: 20
d. ZSize:5
e. ClickOK.

4. From the model history tree, double click on Box1 to open its properties.
5. Change its Name toMagnet.
6. In the model history tree, right-clickMagnet, and select Assign Material.
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7. In the Select Definition window, search for NdFe35, then click Clone Material(s).
8. In the View\Edit Material window:

a. Assign NdFe35_Z as the Material Name.
b. For the Magnitude vectors, assign X Component = 0, Y Component = 0, and Z

Component = 1.
c. ClickOK in the View/Edit Material and Select Definition windows.
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Assign Mesh to Magnet and Run Simulation
To assign a mesh to the permanent magnet:

1. In the model history tree, right click onMagnet, listed under the NdFe35_Zmaterial, and
select Assign Mesh Operation > Inside Selection > Length Based.

2. In the window that opens:

a. Check the Set maximum element length option.
b. Set the value to 1 mm.
c. ClickOK.
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3. In the Project Manager tree, right click on Setup1 (under Analysis), and select Analyze.

View Force and Current Results
1. In the Project Manager tree, right-click on Results, and select Create

TransientAPhiFormulation Report > Rectangular Plot.
2. In the Report window:

a. For the Category, select Layout Force.
b. For the Quantity, use the Ctrl key to select F_GND.Force_Mag and F_VCC.Force_

mag.
c. Click New Report.
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Note: Compare these results with the results obtained without a magnet.
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3. Plot the terminal current for both ports:

a. For the Category, select Terminal Current.
b. For Quantity, select TerminalCurrent(LC1_1_Port1_T1) and TerminalCurrent

(LC1_1_Port2_T1).
c. Click New Report.
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Note: If you see a transient spike at first two time steps, it can be ignored as it is a
numerical artifact. You can adjust the time scale to eliminate the numerical artifact
using the Zoom Area icon from the Desktop's View tab.

For a more precise range, right click in the plot window and selectModify Report, then
click on the ... icon beside the Time field to open a dialog box for specifying a time
range.
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View Field Results on Magnet
1. In the 3D Modeler window, right click on the Magnet, and select Fields > B > Mag_B.

2. In the Create Field Plot window that opens:

a. SelectMag_B as the Quantity.
b. Select Plot Surface Only.
c. Click on theGND and VCC columns to select those nets.
d. Click Done.
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3. Adjust the time step to 30 us, and set the color key scale to Log; if needed, see Field
Visualization for more details.
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View Field Results on Nets
Next you will plot the flux density and current density results on the GND and VCC nets to see
how the magnet affects them.

1. In the Project Manager tree, right click on Field Overlays and select Fields > B >Mag_B.
2. In the Create Field Plot window:

a. Select Plot on surface only.
b. Click on the VCC column label to select all the selectable layers (not all of them are

displayed in the illustration).
c. Click Done.

3. Adjust the time step to 30 us, and set the color key scale to Log; if needed, see Field
Visualization for more details.

4. Compare these VCC results with the field results without the magnet.
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5. Plot theMag_J and J_Vector results for the VCC net. If needed, see Field Visualization
for more details.

J Magnitude results for VCC:
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J Vector results for VCC:
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6. Plot theMag_B, J_Mag and J_Vector results for theGND net. If needed, see Field
Visualization for more details.

B Magnitude results for GND:
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J Magnitude results for GND:
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J Vector results for GND:
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7 - Exit the Electronics Desktop
You have successfully completed the Maxwell-ECAD Integration Getting Started Problem.

1. Save the project plots and reports by clicking File > Save. Ansys Electronics Desktop will
save all data including the plots you have created for later use.

2. To exit the Ansys Electronics Desktop software, click File > Exit.
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